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How to.. Resolve the error "Need admin approval" at login

Summary

After choosing “Microsoft” to login to the SoftwareOne Services Portal (SSP), you are presented with the following error:

image-20240702-150539.png

Or

image-20250409-144314.png

Cause

Your administrator has restricted which applications can authenticate against your workplace EntraID.

Solution

Submit the justification for using the SoftwareOne services portal as requested and click Request Approval, or contact your local Administrator to request access.

This section is for your EntraID Administrator.

Your EntraID’s Enterprise Application “User Consent Settings” are restricting the SSP Enterprise Application's from authenticating your users.

The settings will be within the red area show below

image-20240705-114101.png

You EntraID administrator will need to give the SoftwareOne Cloud Identity application Read access to your EntraID, on the OpenID protocol.

To do that the Administrator can do one of two things:

  1. Change the Consent Settings to allow User Consent

The screenshot below shows the recommended setting

image-20240705-114351.png

The 4 permissions classified as low impact make up the OpenID protocol

image-20240705-114751.png
  1. Review the Request and allow the application.

If you have been able to Request access using the following dialog

image-20240705-115947.png

Your EntraID Admin can review and approve the application request

image-20240705-115743.png

Further reading..

https://learn.microsoft.com/es-es/entra/identity/enterprise-apps/configure-user-consent?pivots=portal

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