Knowledge Base
Breadcrumbs

How to.. Resolve "Need admin approval" at login

Summary

After choosing “Microsoft” to login to the SoftwareOne Services Portal (SSP), you are presented with the following modal:


image-20240702-150539.png

Or

image-20250409-144314.png


Cause

Your IT Administrator has restricted which applications can authenticate against your workplace EntraID.

This page shows what you can do next and info you can share with your Admin in case useful.

Solution

Action for you

  1. Submit the justification for using the SoftwareOne services portal as requested and click Request Approval, for example:

image-20240705-115947.png

When you have done that, you can contact your EntraID admin and ask that they approve your access request.

Action for the EntraID Admin

Check the following sections to allow the SoftwareOne Cloud Identity App:

Enterprise Applications

The user request will be in the Admin Consent Request page of EntraID as shown below:

image-20260219-120237.png

Click on the app to Approve.

Self Service

You might consider allowing the app for self-service:

image-20260219-123555.png

Go to the SoftwareOne Cloud Identity App / Permission section

Click Grant Admin Consent:

image-20260224-131614.png


Further information

For info,the 4 permissions required by the app are shown, classified as low impact in the OpenID protocol:

image-20240705-114751.png

Further reading..

https://learn.microsoft.com/es-es/entra/identity/enterprise-apps/configure-user-consent?pivots=portal