How to.. Resolve the error "Need admin approval" at login
Summary
After choosing “Microsoft” to login to the SoftwareOne Services Portal (SSP), you are presented with the following error:

Or

Cause
Your administrator has restricted which applications can authenticate against your workplace EntraID.
Solution
Submit the justification for using the SoftwareOne services portal as requested and click Request Approval, or contact your local Administrator to request access.
This section is for your EntraID Administrator.
Your EntraID’s Enterprise Application “User Consent Settings” are restricting the SSP Enterprise Application's from authenticating your users.
The settings will be within the red area show below

You EntraID administrator will need to give the SoftwareOne Cloud Identity application Read access to your EntraID, on the OpenID protocol.
To do that the Administrator can do one of two things:
Change the Consent Settings to allow User Consent
The screenshot below shows the recommended setting

The 4 permissions classified as low impact make up the OpenID protocol

Review the Request and allow the application.
If you have been able to Request access using the following dialog

Your EntraID Admin can review and approve the application request

Further reading..
On the SoftwareOne Cloud identity application application, refer to our KB article:Microsoft Authentication Application details
From Microsoft on configuring Consent: